基地台與分享器 - RT-N16 刷tomato 無線無法連線請教 - 電腦

前往內容


RT-N16 刷tomato 無線無法連線請教

前幾天買了RT-N16 刷 tomato-K26USB-1.28.7439MIPSR2-Toastman-VPN.trx 這版,這幾天使用有時會發生搜尋的到基地台 無線信號有4格 可是卻突然連不上 (win7 顯示無法連線到RT-16),確認不是電腦問題,另一台XP筆電也連不上,但有線網路卻是正常(上網正常登入RT-N16也正常),但之前無線連線卻正常,有設WAP2 AES 並鎖網卡,過一段時間.又可正常連上,是tomato設定問題?還是我買到機王.....有人有遇過這種情形嗎?

以下是我無線進階設定

Afterburner(125HSM) 關 *
禁止無線用戶端相互連線 關 *
認證方式 自動 *共用金鑰
基本速率 預設
示標訊號(Beacon)間隔 100
CTS 保護模式 關
管制規定 關
國別 / 地區 臺灣
與藍芽共存 關
距離 / ACK 調速 0
DTIM 間隔 1
Fragmentation 臨界值 2346
框架連發(Frame Burst) 關
無線用戶端最大數量 128
多點傳播速率(Multicast Rate) 自動
前導同步訊號(Preamble) 長
802.11n 前導同步訊號 自動
重疊 BSS 共存 關
RTS 臨界值 2347
接收天線 自動
發射天線 自動
發射功率 mW 17
傳送速率 自動
無線多媒體(WMM) 開
無雙向確認(No ACK) 關
APSD 模式 開

ps : 刷 tomato-K26USB-1.28.905xRAF-ML-MIPSR2-070V-AIO.trx 這版也會有如板上之前討論(某些tomato版本),XP 電腦無法登入 ,win 7 卻可以登入情形,目前這問題有解嗎?
找到斷線原因了,只要中華電信MOD在開啟,無線就斷線連不上(信號正常但連不上),但此時有線連線都正常,為了讓行動裝置上網跟電腦pppoe 取得真實IP,所以我N16跟P874是以 兩條線對連 所以我的接法是P874後面接N16 p874 lan->n16 lan 跟 p874 lan ->n16 wan ,然後 n16 lan拉一條線到樓下Switch hub 接 PC 與 MOD,試過土司跟泰迪熊的版本都會降,請問這是這種接法造成無線連不上還是需要改tomato的設定?有辦法解決嗎?
剛測試一下,把P874->N16的wan線拔掉 剩P874 lan-N16 lan mod改到P874的 lan4 ,P874設定內mod設到lan4無線還是會斷,若把P874 lan-N16 lan拔掉,剩P874 lan->N16 wan 無線就正常,搞不清原因出在哪...
我也遇到一樣的狀況,目前無解中....

重新說明一下狀況,請了解網路設定的前輩們幫忙看看


實體網路配置:

DSL-6641K => ASUS N16 => Switch => MOD及其他設備

這邊6641K拉了兩條線到N16,一條拉到N16的WAN,一條拉到N16的LAN
因為家中實體配置的關係,所以MOD一定得接在分享器後面
所以又從N16拉了一條線接到6641K上,讓MOD與小烏龜能夠在同一個網域下

這種設定,使用ASUS原廠的FW是可以實行的,各個設備都可運作無誤

但是換刷成TOMATO後,MOD依然可以看,有線網路也沒有問題
但是無線網路wifi的部份就出問題了
手持裝置都可以搜尋得到基地台,但是就是無法成功連線

把N16 LAN端拉到小烏龜的線拔掉的話,無線網路就恢復正常

猜測是TOMATO的某些設定造成的
但是目前仍然抓不出來

還請各位大大幫忙dubug一下


感謝

deepwhite wrote:
我也遇到一樣的狀況,...(恕刪)

問題在一條拉到N16的WAN,一條拉到N16的LAN
這方法要視分享器晶片,並不是所有分享器都可以這麼做.

因為TOMATO本身有VLAN功能可對應MOD,所以用內建功能便解決了.

感謝gfx兄提供的解決方法

這個方法的確可以解決大部分人的需求(MOD直連AP,然後直通小烏龜)


但是小弟因為當初的配線失誤,家中網路的集中處是在MOD旁
所以大部分的裝置是跟MOD平行的

小烏龜 => n16 => switch

switch後才是MOD及大部分的裝置
所以若是切vlan把MOD那個port直通小烏龜,那共用此線的其他裝置也等同直通小烏龜,無法使用n16的功能了

一條線接wan,一條線接lan的確是不符合網路常識的接法,但是目前這麼做可以解決MOD的問題,而且並沒有其他明顯後遺症,所以我還是採用此種接法。

若有網兄能有更好的解決方式,也還請希望告知,因為經過大量爬文,好像也有許多人有類似困擾。

剛剛我把n16刷回ASUS原廠韌體
一開始也會有相同情況
但是我把IPTV中的設定改成這樣後

再把AP重開

"啪"一聲以後,所有的裝置又work了,wifi也可以正確連上了

我的網路知識不足以解釋為何可以,又為何不行的問題
也不知道tomato有沒有哪個選項可以達到跟ASUS原廠韌體一樣的效果
只是在一堆的爬文及錯誤嘗試後,找到的一個看似ok的解決方案


若有網兄能夠解釋箇中原因,或是有更好的解決方案,還請不吝分享

感謝
我的N16刷的版本是 MIPSR2-105 K26 USB AIO
自從刷完後,就遇到跟第一篇一樣的情況
重開機才會好,但是很快(12小時內)又會出現一樣的問題
無線偶而會連不上,有線都正常

我也有辦MOD
也有從小烏龜接兩條線到N16(一個接WAN,一個接 Lan)

昨天把 Advanced > Firewall > Multicast > Enable IGMP Proxy 選項停用了
到現在超過24小時,無線還沒連不上過
你參考看看 :)

1頁 (共1頁)

前往