[研究所] MikroTik RouterOS 學習 (持續更新)


alwayssmileruten wrote:
這個部分可設定未經過...(恕刪)

這部份小弟先用你的方式在walled garden ip list 加入192.168.0.0/24這個網段試看看。所以區網部份也需要驗證?怪哉
感謝回覆
calven.lai wrote:
但目前設定,重開機 有可能會是其他的pppoe 抓到ipv6 權利 變成ipv6 dhcp 要重新設定/對映一次

不就是這樣的設定,沒遇過您說的情況

是這樣設定
但是這是在單一一個pppoe

我目前是四個 pppoe
3個pppoe ip mapping 各對一個lan ip
ipv6 重開機之後 就會出現如附件的問題




這時候
要看 ipv6 address

interface 的部份 誰拿到 ipv6 ( 看第二行)

再在 dhcpv6 client 中設定interface

才能通

calven.lai wrote:
ipv6 重開機之後...(恕刪)

雖然不懂原因,但總可以刪除電腦定的fe80::9/64 的pppoe-out3
自己手動新增一個fe80::9/64 的pppoe-out1吧
印象中試過,沒有用

因為ipv6 的權利,已經給 先拿到的pppoe介面

加設定之後 沒有效果,在dhcpv6 client 會無法bound


另,是否有 pppoe . ip mapping 的設定方式,官方也沒這方面的資訊
pctine大您好:

有來麻煩您了,目前使用的網路是HINET 7動態IP+1固定IP , 動態IP及固定IP都是使用PPPOE!!

在ROUTEROS 的設定
Ether1 pppoe 固定ip 架站使用
Ether2 pppoe 浮動ip 一般上網使用
Ether3~5 LAN (IP都同一區段)

目前遇到的問題是在區域網路內,直接輸入所架設網站的網址(www.zzz.com.tw),都無法顯示網站,而要輸入LAN IP(192.168.1.100) 才可顯示,但非區域網路內的電腦,輸入網址都可正常顯示,請其他朋友測試也可正常顯示!!請問該如何設定??不吝指教,謝謝!!


ken-1976 wrote:
目前遇到的問題是在區域網路內,直接輸入所架設網站的網址(www.zzz.com.tw),都無法顯示網站,而要輸入LAN IP(192.168.1.100) 才可顯示,但非區域網路內的電腦,輸入網址都可正常顯示,...(恕刪)


這在最前面幾篇有提到, 是 NAT loopback 的問題, 解法大致有二種.

1.你找一下有關 RouterOS Hairpin NAT.
2.用 DNS 來解, 也就是你在內網輸入 www.zzz.com.tw 時, 讓它解到 web server LAN IP.
FB:VoIP電話技術交流
RouterOS Multi SSID & 訪客 wi-fi 限流實作

網友 PM 詢問有關 RouterOS 內建 wi-fi 機種如何達到多組 SSID, 並針對訪客使用的 wi-fi 做限制流量.

這裡是以 RB2011UAS-2HnD 內建 wi-fi 機種做說明:


# ether2-local-master 和 wlan1 建立 bridge
/interface bridge
add arp=proxy-arp l2mtu=1598 name=bridge-local
/interface bridge port
add bridge=bridge-local interface=ether2-local-master
add bridge=bridge-local interface=wlan1


# 建立 wireless profile
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=\
tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=klhome2 \
supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=\
"XXXXXXXX\$" wpa2-pre-shared-key="XXXXXXXX\\$"
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=\
tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=\
profile1 supplicant-identity="" unicast-ciphers=tkip,aes-ccm \
wpa-pre-shared-key=guestonly wpa2-pre-shared-key=guestonly

# 設定 wlan1 & 新增 wlan2 virtual-ap (multi SSID)
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2427 \
l2mtu=2290 mode=ap-bridge security-profile=klhome2 ssid=klhome \
wireless-protocol=unspecified
add disabled=no l2mtu=2290 master-interface=\
wlan1 name=wlan2 security-profile=profile1 ssid="klhome guest" \
wds-cost-range=0 wds-default-cost=0

# wlan2 設為另一個網段 192.168.39.0/24
/ip address
add address=192.168.38.1/24 comment="default configuration" interface=\
ether2-local-master network=192.168.38.0
add address=192.168.39.1/24 comment=wlan2 interface=wlan2 network=\
192.168.39.0

# wlan2 dhcp server
/ip dhcp-server
add address-pool=dhcp_pool2 disabled=no interface=wlan2 name=dhcp1
/ip dhcp-server network
add address=192.168.39.0/24 comment=wlan2 dns-server=192.168.38.1 gateway=\
192.168.39.1


在前面主要是建立出 wlan2 Virtual-AP. 並把 wlan2 獨立出來為另一個網段.
接下來只要利用 simple queue 做流量限速即可.(此例為 downoad/upload = 2MB/1MB 為例)

/queue simple
add max-limit=1M/2M name=queue1 target=192.168.39.0/24




這裡是以 RouterOS v6 為例, 在 v6 裡把 Queue 的一些設置簡化了許多, 例如在 v5 多了 Interface 選項, 但在 v6 它和 Target 合併了. 此部份網友可以參考 Mikrotik wiki

驗證
可以直接利用 speedtset.net 網站做粗略的測試.
測試的數據和所設定的 2M/1M 相當接近.


或是直接利用原廠提供的 btest tool 做頻寬的測試.

(ps:btest tool 如果啟用雙向測試時,其TX/RX數據好像相反了,如上圖,跟原廠反應過,但現階段原廠沒有打算去改正它,大家知道就好了.)
FB:VoIP電話技術交流
評分
複製連結
請輸入您要前往的頁數(1 ~ 736)