[研究所] MikroTik RouterOS 學習 (持續更新)

請問各位前輩有這樣的經驗嗎?
小弟買了450g做為主要的router後面穿串接之前使用的router,在使用網路有個困擾
當電腦或手持平板在用網路時,如開網頁閱讀過大約10幾分鐘要再開下一頁時都會卡住一下,但等順了之後再開其它不同網頁就又很順暢
感覺有點像是休眠狀況,請問要如何設定呢?讓系統可以持續連線
小弟使用的網路是cable連線
我之前遇到過,不過後來証實是ap的問題,routeros強烈建議不要使用realtek or ralink solution的AP,常常連機器修眠以後連IP都不見了...

phoenix2004 wrote:
常常連機器修眠以後連IP都不見了......(恕刪)


機器休眠是指 pc 嗎? 既然都睡著了, 那 IP.....
FB:VoIP電話技術交流
不是,我意思是iPad or iphone按下關閉螢幕,常常再打開連IP都不見了,然後DHCP還抓不到,log只看到一堆DHCP warning訊息,本來還以為是我哪裡沒設好,後來全部換成boardcom跟atheros solution的AP就沒有發生過了

phoenix2004 wrote:
不是,我意思是iPa...(恕刪)


呵, 這就怪了, routerboard 跟 realtek or ralink ap 不合? 問題是一般互連是用網線, 不致於發生這個問題. 你直的要查可能去 capture 封包看看.
FB:VoIP電話技術交流
後來換掉就解了就不想去深究了...

可能是因為我都是把AP設固定IP,關閉router/NAT的關係,後來代理商有自己承認realtek ap建議我設成router mode,用那台ap來發IP,應該就不會遇到這個問題,但是基本上很不喜歡這樣做,最後就換掉AP了..
Netwatch & e-mail tool

RouterOS 內建有相當多實用的工具程式. 其中 netwatch 可以透過 ping 的方式持續對特定主機做 alive check.

例如 192.168.10.1 是 VPN 連線的遠端 gateway, 透過設定 netwatch 排程監控, 一斷線就發訊息通知網管人員.


其中 up & down 是根據線路狀態, 系統會自動執行該 script.


/log warning "host 192.168.10.1 down"

# send email
/tool e-mail
set address=203.69.82.30
set port=25
set from=xyz@mail2000.com.tw
set user=xyz
set password=yourpassword
send to=xyz@mail2000.com.tw subject="192.168.10.1 host down" tls=yes


這只是大致的應用, 其他發簡訊等可依據自己的需求修改 script.

從 Gmail 寄信可以參考這裡
FB:VoIP電話技術交流
/tool torch - Real-time traffic monitor

有時候上網 Lag 時, 我們會透過一些 Tool 去解決問題, 在以前使用的 Vigor router 有一個蠻好用的工具 - Data Flow Monitor, 可以看到各個 client 的 upload/download 流量及 connection 數.


在 RouterOS 中除了各個功能有很多的即時流量統計圖表外, 其中以 Torch 算是小弟較常使用的 Tool. 於 winbox > Tools > Torch 執行之.


一般要查詢各個 client 的連線狀態, Interface 選擇 ethernet LAN 即可, 而各Filter 可以根據自身的需要填入過濾. 它顯示的是即時連線狀態, 並非統計後的結果, 不過大致上對於 troubleshooting 已很有幫助.

另外在 ip firewall connections & ipv6 firewall connections 也有即時連線訊息可供查詢. 在 tools 底下還有一個 sniffer tool, 可以用來截取封包, 一般我們在 debug 時常常要 capture 封包, 透過設定 router 上 mirror port & 執行 wireshark 來做, 在 RouterOS 上已提供 sniffer 功能, 可以將截取下來的封包存檔及下載, 除了 online 可以檢視外, 並可下載後在 wireshark 中開啟檢視, 在使用上也方便許多.

補充
之前提過 Simple Queue + PCQ 做頻寬的動態分配, 今天一方面用 NAS 在執行 BT 下載, 另一方面 PC 端觀看 youtube 上 1080p 影片, 結果發現 PC 端的 youtube 非常 lag, 不是已經做頻寬的 '有效分配' 了嗎? 進入 NAS download station 發現它吃滿了所有下載頻寬, 難怪 PC 端非常 lag, 敢是 routeros queue 未發揮作用?

後來進入 winbox, 透過 connections & torch, 發覺原來有很多的 BT 採用IPv6 連線. 但在 queue 裡面小弟的一些設定是以 IPv4 做為條件, 造成沒有被'queue'住, 此部份必須再調整 queue 的設定才行.


FB:VoIP電話技術交流
給你N個讚,謝謝大大說明~~~~感激!!
想问一下有没有人知道如何在 RouterOS 里面实现 dnsmasq 的功能?

谢谢!!
評分
複製連結
請輸入您要前往的頁數(1 ~ 735)