[研究所] MikroTik RouterOS 學習 (持續更新)

oashin wrote:
抱歉小弟遇到一個問題...(恕刪)

其實兩台NAS Port-Forwarding就可以搞定,不需用到兩個IP啦!

如DS-Web:
NAS1(192.168.88.30)




NAS2(192.168.88.31)




假如您的固定ip是220.123.123.123
要用DS-web連接NAS1 ,就地址輸入220.123.123.123:1000
要用DS-web連接NAS2 ,就地址輸入220.123.123.123:2000

Dst Port改用您喜歡的Port就可以避開,沒規定一要用5000的.
另外其它的連接也是一樣的方法.
oashin wrote:
抱歉小弟遇到一個問題...(恕刪)

假如還是想要讓NAS1/NAS2使用不同的浮動IP,然後用DDNS對應...

1.在RB450G新增兩組新的pppoe-out2/pppoe-out3 ,Add Default Route請勿勾選.

2.與pppoe-out1同,到/ip firewall nat
新增兩筆scrnat,將pppoe-out2/pppoe-out3給masquerad

3.在/system scheduler新增startup開機撥號的腳本
http://www.mobile01.com/topicdetail.php?f=110&t=3205444&p=124#47298361
依您的pppoe-out數量修正腳本.
這很重要,不然每次重開機Dual Stack會因多個pppoe同時撥號順序不同而跑掉設定.

4.設定策略路由,到/ip firewall mangle
新增NAS1:



新增NAS2:
參考NAS1 ,Routing Mark設定為to_pppoe-out3

5. /ip route
新增NAS1:


新增NAS2:
參考NAS1 ,Gateway設定為pppoe-out3 ,Routing Mark設定為to_pppoe3

6.設定dmz ,到/ip firewall nat
新增NAS1:
將pppoe-out2連線都轉址到192.168.88.30



新增NAS2:
參考NAS1 ,將pppoe-out3連線都轉址到192.168.88.31

7.結束...大功告成!

gfx wrote:
我也想試用SSTP啊...(恕刪)


我是買PCHome代管的Domain Name~
沒辦法~要花錢才能有的~
gfx大 感謝您的教學,小弟 試試看
謝謝!! gfx、pctine、虎._."三位大大
將成功的固定制IPV6設定分享給大家。


註:
另外,想問一下RouterOS有辦法根據連結到的IP位置(或國家區域),使用指定的DNS伺服器做域名查詢嗎?
例:220.130.158.71(台灣)->指定使用168.95.1.1這台DNS伺服器做域名查詢。
昨天把NAS開放給朋友,讓朋友能從NAS下載或觀看影片.
結果一開放,才知道中華的60/15M...15M上載是多麼的吃緊!

不給Qos限速的話BT下載+Skype視訊+友人的流量+網頁瀏覽使用上會有很大的問題,
於是開始著手,從次要的BT下載 和友人的流量做限制,讓Skype視訊 和網頁瀏覽能擁穩定的頻寬.

我是用時間做標記來對上載做控制,歡迎各位指正
正確的時間ROS會用黑色字體顯示正運作中;不然會以紅色字體代表目前暫不予以工作.
/ip firewall mangle
add action=mark-packet chain=postrouting comment=\
"DSM->The Friends 22:00:00-02:00:00\AD\AD\B3t8M" dst-address-list=friends \
new-packet-mark=to_friends passthrough=no src-address=192.168.88.108 time=\
22h-1d,sun,mon,tue,wed,thu,fri,sat

add action=mark-packet chain=postrouting dst-address-list=friends \
new-packet-mark=to_friends passthrough=no src-address=192.168.88.108 time=\
0s-2h,sun,mon,tue,wed,thu,fri,sat


add action=mark-connection chain=postrouting comment=Transmission dst-port=\
!80,443,139,445,1723 new-connection-mark=Transmission protocol=tcp \
src-address=192.168.88.2 src-port=!1723,1194

add action=mark-connection chain=postrouting new-connection-mark=Transmission \
protocol=udp src-address=192.168.88.2 src-port=51515

add action=mark-packet chain=postrouting comment=\
"Transmission [Sun~Sat] 00:00:00-03:00:00\AD\AD\B3t2M" connection-mark=\
Transmission new-packet-mark=p2p_out_limit.2M passthrough=no time=\
0s-3h,sun,mon,tue,wed,thu,fri,sat

add action=mark-packet chain=postrouting comment=\
"Transmission [Mon~Fri] 03:00:00-19:00:00\AD\AD\B3t8M" connection-mark=\
Transmission new-packet-mark=p2p_out_limit.8M passthrough=no time=\
3h-19h,mon,tue,wed,thu,fri

add action=mark-packet chain=postrouting comment=\
"Transmission [Mon~Fri] 19:00:00-24:00:00\AD\AD\B3t2M" connection-mark=\
Transmission new-packet-mark=p2p_out_limit.2M passthrough=no time=\
19h-1d,mon,tue,wed,thu,fri

add action=mark-packet chain=postrouting comment=\
"Transmission [Sat~Sun] 03:00:00-10:00:00\AD\AD\B3t8M" connection-mark=\
Transmission new-packet-mark=p2p_out_limit.8M passthrough=no time=\
3h-10h,sun,sat

add action=mark-packet chain=postrouting comment=\
"Transmission [Sat~Sun] 10:00:00-24:00:00\AD\AD\B3t2M" connection-mark=\
Transmission new-packet-mark=p2p_out_limit.2M passthrough=no time=\
10h-1d,sun,sat


/ipv6 firewall mangle
add action=mark-connection chain=postrouting comment=Transmission dst-port=\
!80,443 new-connection-mark=Transmission_v6 protocol=tcp src-address=\
2001:b010:3380:e01:bcae:c5ff:fec3:7eaa/128

add action=mark-connection chain=postrouting new-connection-mark=\
Transmission_v6 protocol=udp src-address=\
2001:b010:3380:e01:bcae:c5ff:fec3:7eaa/128 src-port=51515

add action=mark-packet chain=postrouting comment=\
"Transmission [Sun~Sat] 00:00:00-03:00:00\AD\AD\B3t2M" connection-mark=\
Transmission_v6 new-packet-mark=p2p_out_limit.2M passthrough=no time=\
0s-3h,sun,mon,tue,wed,thu,fri,sat

add action=mark-packet chain=postrouting comment=\
"Transmission [Mon~Fri] 03:00:00-19:00:00\AD\AD\B3t8M" connection-mark=\
Transmission_v6 new-packet-mark=p2p_out_limit.8M passthrough=no time=\
3h-19h,mon,tue,wed,thu,fri

add action=mark-packet chain=postrouting comment=\
"Transmission [Mon~Fri] 19:00:00-24:00:00\AD\AD\B3t2M" connection-mark=\
Transmission_v6 new-packet-mark=p2p_out_limit.2M passthrough=no time=\
19h-1d,mon,tue,wed,thu,fri

add action=mark-packet chain=postrouting comment=\
"Transmission [Sat~Sun] 03:00:00-10:00:00\AD\AD\B3t8M" connection-mark=\
Transmission_v6 new-packet-mark=p2p_out_limit.8M passthrough=no time=\
3h-10h,sun,sat

add action=mark-packet chain=postrouting comment=\
"Transmission [Sat~Sun] 10:00:00-24:00:00\AD\AD\B3t2M" connection-mark=\
Transmission_v6 new-packet-mark=p2p_out_limit.2M passthrough=no time=\
10h-1d,sun,sat


/queue tree
add limit-at=8M max-limit=8M name=to_friends packet-mark=to_friends parent=pppoe-out1 \
queue=default

add limit-at=8M max-limit=8M name=p2p_out_limit.8M packet-mark=p2p_out_limit.8M \
parent=pppoe-out1 queue=default

add limit-at=2M max-limit=2M name=p2p_out_limit.2M packet-mark=p2p_out_limit.2M \
parent=pppoe-out1 queue=default
kclonline wrote:
將成功的固定制IPV6設定分享給大家。...(恕刪)


感謝分享, 所以大大沒有設定IPv6 ND 嗎?


另外,想問一下RouterOS有辦法根據連結到的IP位置(或國家區域),使用指定的DNS伺服器做域名查詢嗎?
例:220.130.158.71(台灣)->指定使用168.95.1.1這台DNS伺服器做域名查詢。


可否先請教一下, 這樣的用意是??
FB:VoIP電話技術交流
小弟在內網 192.168.1.11 架了台 Web Server (Listen Port 80,443)
也順利從外部可以進到 Web Server 讀取資料,
但是內網的 PC 無法使用 Public IP 來進入 Web Server ,
我想就是所謂的 Hair pin loopback 的問題,
看了一些文件, 設了許多次還是沒有成功,
是不是可以請高手幫忙一下 :

Web Server : 192.168.1.11
Public IP : 1.2.3.4
ether1 撥接 Hinet-VDSL-PPPOE1
ether2 連結內部 Switch (192.168.1.0/24)

nat 內總共有兩條規則 :

/ip firewall nat

(1)
chain=dstnat action=dst-nat to-addresses=192.168.1.11 protocol=tcp
dst-address=1.2.3.4 in-interface=Hinet-VDSL-PPPOE1 src-port=""
dst-port=80,443

(2)
chain=srcnat action=masquerade


是要在哪邊加入一條 nat rule 嗎?
謝謝 !
Cowbell wrote:
小弟在內網 192....(恕刪)

若只是想加NAT Loopback ,加這行指令就好了
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.1.0/24

Cowbell wrote:
小弟在內網 192....(恕刪)


IP底下有一個DNS的功能。
你可以用名稱來對應LAN IP。
這可能會比較方便一點。
irsjx2vxo3ne3k84dr1dz4,r4pe8bez3/4ne3bq4bew2j92gea jx4hq me-2d8 e3hy4hi2ty k84!
評分
複製連結
請輸入您要前往的頁數(1 ~ 736)