[研究所] MikroTik RouterOS 學習 (持續更新)

你參考看看, 小弟試過可以正常寄信的.

Send logs from gmail


#SMTP伺服器位置
:local SMTP "smtp.gmail.com"
:local PORT "587"
:local TLS "yes"

#SMTP認證
:local USER "[email protected]"
:local PWD "yyyy"

#寄件人
:local MailFrom "[email protected]"

#收件人
:local MailTo "[email protected]"

#寄出後是否刪除已存檔的Log(/file裡的檔案)
#0=保留 1=刪除

:local DeleteLogFile 1

:local BackupFileName
:set BackupFileName ([/system identity get name] . "_Backup-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
/system backup save name=($BackupFileName);
delay 10;

/tool e-mail set from=$MailFrom;
/tool e-mail set address=[:resolve $SMTP];
/tool e-mail set port=$PORT
/tool e-mail set user=$USER
/tool e-mail set password=$PWD
/tool e-mail set start-tls=$TLS

/tool e-mail send to=$MailTo subject=([/system identity get name] . " -- RouterOS Backup " . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]) file=[$BackupFileName];

:delay 10;


如果搭配其他家的 mail server, 一般 port number 要改為 25, TLS 設定為 "no", 但具體的設定還是依每家 mail server 做更改.
FB: Pctine

chemyuan wrote:
設定跟你一樣原本都還...(恕刪)


有關email,以下是我的經驗

台灣Hinet RB2011 可寄
上海辦公室 RB751 可寄
上海家(不同ISP) routeros x86 5.2 版寄不出去。再改用 RB750 v6.7 寄不出去。火大買了台 RB2011 更新到 v6.7 還是寄不出去

其間也碰到過 TLS 問題,需要修改 script。還是寄不出去。

這幾台的 script 確定是一樣的。mail server 是 gmail。我猜,會不會是 router 寄 email 時不會主動走 VPN,然後 gmail 又被當地 ISP 擋。。。我若改用大陸當地的 mail server 測試後就知道我的假設對不對了。但最近忙就懶的理他。

不知道你是在台灣嗎?也許我們的問題是一樣的,且也許問題不在 gmail 被大陸擋。。。
我的router 是放在台北
在更新前都正常可以寄信的
單車全記錄................................... http://blog.xuite.net/chemyuan/bike

chemyuan wrote:
我的router 是...(恕刪)


#1811 樓 script 試過還是不行??
FB: Pctine

chemyuan wrote:
TLS = YES ...(恕刪)


1.檢查你的防火牆看看有無封鎖。
2.檢查你的SMTP SERVER IP是否正確。
3.先不要寄附件,只寄空白的MAIL試試。
4.tool email裡面有一個test email的功能,你可以先在那邊測試看看。
謝謝
試過了
還是寄不出去
pctine wrote:
你參考看看, 小弟試...(恕刪)
單車全記錄................................... http://blog.xuite.net/chemyuan/bike
1.防火牆沒封鎖
2.74.125.128.108:587
3.有沒有附件都寄不出去
4.試過了一樣是錯誤訊息...Error send e-mail....

找個時間重置系統試試
單車全記錄................................... http://blog.xuite.net/chemyuan/bike

chemyuan wrote:
1.防火牆沒封鎖2....(恕刪)


先不要管 routeros, 你用 outlook or outlook express 先試看看, 能寄出去嗎?
FB: Pctine
Mikrotik 教育訓練中心 (Train Center)

自從開始使用 Mikrotik RouterOS 後, 絕大多數都是透過原廠官網 wiki & 眾多網友分享的分享及教學文做為自學教材, 但透過 wiki & 教學文中所習得的知識很多都是片面的, 再加上 RouterOS 版本不斷的變更及升級, 常常有些設定套用在新版 firmware 時不見得能夠 work, 常常在找尋 Mikrotik 原廠是否也有像 Cisco 般成立原廠授權的教育訓練中心? 但很可惜的是台灣並沒有此教育訓練中心, 最近的訓練中心可能就是深圳了. 所以小弟平時也只能看看官網上面的 (MUM-Mikrotik User Meeting) 錄影過過乾癮.

剛才網友分享了一則在台灣第一次舉辦的 Mikrotik MTCNA 訓練課程, 原廠認證最主要有下列數種:

Approved MikroTik training programs and certificates:

MTCNA - MikroTik Certified Network Associate (view outline)
MTCRE - MikroTik Certified Routing Engineer (view outline)
MTCWE - MikroTik Certified Wireless Engineer (view outline)
MTCTCE - MikroTik Certified Traffic Control Engineer (view outline)
MTCUME - MikroTik Certified User Management Engineer (view outline)
MTCINE - MikroTik Certified Inter-networking Engineer (view outline)

MTCNA 應該算是 Mikrotik 認證的第一關吧! 但仔細看了一下, 三天密集的課程, 排的緊湊又很紮實, 如果不是這次開課日期和香港春季電子展沖到了, 小弟無法參加, 不然也想去把 RouterOS 功夫練的深入些.

台灣首次 Mikrotik 原廠訓練課程

(課程節錄)
2014/04/16:網路資安防火牆 | 流量頻寬管理 | 縝密的網管功能
2014/04/17:無線網路基本觀念剖析|無線通訊協定進階解說|無線橋接功能介紹
2014/04/18:RouterOS 使用概述|超強路由功能解析|VPN功能精解實作

詳細的內容請自行參考, 通過這三天課程及認證考試, 應該也算是 RouterOS 專家級了!
FB: Pctine
用PC寄都OK
pctine wrote:
你參考看看, 小弟試...(恕刪)
單車全記錄................................... http://blog.xuite.net/chemyuan/bike
關閉廣告
文章分享
評分
複製連結
請輸入您要前往的頁數(1 ~ 772)