[研究所] MikroTik RouterOS 學習 (持續更新)

小淺 wrote:
可以讓每個port都走不同的PPPoE撥號出去(一個WAN撥多次)嗎?
也就是說每個port出去的IP都不同,
但內網還是在同一個網段 192.168.88.x...(恕刪)


據了解是可以, 可以 PPPoE 多次撥號, 根據 src-address, src-port, dst-address, dst-port 走不同的路由, 但你實際上的運用方式是?
FB:VoIP電話技術交流

pctine wrote:
據了解是可以, 可以...(恕刪)


我想讓某個port上的電腦用固定IP(ip.hinet.net)出去,
其他電腦就用動態IP,
不希望全部的人都用那組固定IP。
Multi-Session PPPoE & 指定路由的做法

小淺 wrote:
我想讓某個port上的電腦用固定IP(ip.hinet.net)出去,
其他電腦就用動態IP,
不希望全部的人都用那組固定IP。...(恕刪)


你這個指的 port 實際上應該是 source address, 做法如下.

假設 pppoe-out1 是取得固定 IP 撥號, pppoe-out2 是取得動態 IP.

1.建立 pppoe-out1 client, add default route=no
2.建立 ppooe-out2 client, add default route=yes
3.假設你要走固定IP出去的電腦 IP=192.168.38.200, 這裡利用 mangle 做 mark-routing


/ip firewall mangle
add action=mark-routing chain=prerouting comment="mark route" disabled=no \
new-routing-mark=wan1 passthrough=yes src-address=192.168.38.200


4.在 ip route 加入路由. 前面標記為 wan1的, 這裡指定它由 pppoe-out1 出去.

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
routing-mark=wan1 scope=30 target-scope=10


這樣就達到你要的要求了. 其他的變化就是搭配 VPN Tunnel & address-list, 例如 Taiwan & China 建立 VPN, 在 China Router 上建立 Policy Route, 只要屬於台灣網段的網站就往 VPN Tunnel 走. 其他就還是走 China ISP 當地的線路.

*****************************************************************************
2013/03/01 補充:

事實上以上的設定是有問題的, 之前在實測上就發現雖然我們 default gateway 指向 pppoe-out2, 但兩路 PPPoE 撥號連線的先後卻會造成系統有時並不按我們指定的路由走. 這問題應該是在小弟的實測中, 兩路 PPPoE 是同一個 ISP(利用中華電信允許同一帳號多撥), 所取得的 gateway IP 也都相同, 所以必須要特別以 check gateway 來判斷 PPPoE 連線是否正常.

修正如下:
1.建立 pppoe-out1 client, add default route=no
2.建立 ppooe-out2 client, add default route=no
3.ip route 手動加入 default route.

而在 ip route 設定時 Check Gateway 一定要指定以 ping 的方式 check.(check-gateway=ping)

這樣才能正常 work.
FB:VoIP電話技術交流
pctine wrote:
你有先做 IP &a...(恕刪)


不好意思,請問pctine大哥 IP & MAC 是要把每一台連接的手持裝置,電腦以及分享器都打上去嗎?
因為我家的wifi算半開放式的,給來的客人都可以使用,所以很難掌控每個手持裝置的MAC


此外,想再請教大哥的問題是
1.我分享器IP設定為192.168.1.1-15
DHCP為192.168.1.100-200 這樣設定對嗎?
因為我有將asus n16 掛載P2p 軟體,可是沒封鎖p2p 但機器沒法下載
而我試著用dnz 設定該台分享器還是沒法下載
已解決囉


2.我將asus n16串接在ether2這個線路上,而ether3的電腦要連接asus n16 的網路硬碟找不到
可是ether3的電腦找的到ether2上的電腦和網路印表機,(電腦和網路印表機的IP是由 MikroTik發送的)
網頁直接打IP也可以進去設定該台分享器就是找不到網路硬碟

可能要再麻煩pctine大哥幫忙或是有其他前輩可以幫忙指點
dda27 wrote:
IP & MAC 是要把每一台連接的手持裝置,電腦以及分享器都打上去嗎?
因為我家的wifi算半開放式的,給來的客人都可以使用,所以很難掌控每個手持裝置的MAC


前面那個範例就是要求 IP & MAC 要完全對應, 不讓未登記的設備上網, 如果你有客戶需上網, 就不適合此種做法.


1.我分享器IP設定為192.168.1.1-15
DHCP為192.168.1.100-200 這樣設定對嗎?


至於你第二個問題, 僅是把 RT-N16 做為一般 AP 使用, 你的解法自然沒有問題. 只是買一台 RT-N16 只當做 AP 使用, 是有點浪費些了.
FB:VoIP電話技術交流

pctine wrote:
如果是指由 client 連線至 PPTP Server 就依照我前們所寫的那個設定做就可以了. 不然你把你的設定或擷圖貼上來吧! 大家看看是那裡出了問題.

小弟的建議是,在連線後你必須去觀察 VPN 兩端點各自所取得的 IP, 還有 route 的變化, 這樣你就很容易找到問題點. 下面是假設為 PPTP VPN LAN-to-LAN.


太利害了 ,照這個 routing 的方式,我 site to site 的 OpenVPN,client to client 可 ping 的到了 :)

pctine wrote:
如果是指由 client 連線至 PPTP Server 就依照我前們所寫的那個設定做就可以了. 不然你把你的設定或擷圖貼上來吧! 大家看看是那裡出了問題....(恕刪)


情況回報!
小弟原先192.168.8.2~20並沒有在RB450G DHCP的分派範圍內,而是保留來指定機器的固定IP。
後來我手動去DHCP Server的Lease中手動添加這些機器的固定IP與MAC對應。
現在用PPTP連上RB450G已經可以ping到RB450G的區網,但用OVPN還是不行。

另外還有一件有趣的事。
我的NAS也在RB450G之後,但以OVPN先連上NAS的話,卻可以ping到RB450G的區網:)
irsjx2vxo3ne3k84dr1dz4,r4pe8bez3/4ne3bq4bew2j92gea jx4hq me-2d8 e3hy4hi2ty k84!
pctine wrote:
Multi-Ses...(恕刪)


謝謝pctine大,忘記說明,我指的port是機器上的實體網路孔,
照大大提供的指令輸入已經成功了,
建立PPPoE Client連線的順序很重要,顛倒就失敗。

另外我想說第3步的src-address有辦法改成用interface來判斷嗎?

建立PPPoE Client連線的順序很重要,顛倒就失敗。


這個部份我了解你所遇到的問題, 此部份小弟覺得是 RouterOS 的問題, 待我問過原廠.

小淺 wrote:
另外我想說第3步的src-address有辦法改成用interface來判斷嗎?...(恕刪)


你自己可以試看看,

例如你的 ether4=192.168.10.1/24, ether5=192.168.11.1/24,
in-interface=ether4...
in-interface=ether5...

自己動手做看看, 再來分享吧!
FB:VoIP電話技術交流
derliang wrote:
小弟原先192.168.8.2~20並沒有在RB450G DHCP的分派範圍內,而是保留來指定機器的固定IP。
後來我手動去DHCP Server的Lease中手動添加這些機器的固定IP與MAC對應。...(恕刪)


你指的 secret or profile 裡面的 local address & remote address, 它指的是 VPN 建立後系統所自動 bind 在 local & remote 兩端的 address 就比較容易理解它的原理, 不要想成是 '配發IP'.

至於你說的 OpenVPN, 跟著做可能會, 但理論這部份我是完全不懂, 待日後有學到再來分享.
FB:VoIP電話技術交流
評分
複製連結
請輸入您要前往的頁數(1 ~ 736)