[研究所] MikroTik RouterOS 學習 (持續更新)


derliang wrote:
如果把Master的LAN port橋接的話,建立在master port上的DHCP Server就會失效...(恕刪)


你既然設 bridge, 那麼 dhcp server 應該設在 bridge 這個 interface 上.
FB:VoIP電話技術交流

pctine wrote:
你既然設 bridge, 那麼 dhcp server 應該設在 bridge 這個 interface 上.


嗯嗯,的確這樣就ok了。
想再請教一下,設了新Bridge以後,那麼IPv6的address要設在那個interface 呢?
以後的防火牆LAN的interface是bridge1還是原來的ether2-master-local呢?
irsjx2vxo3ne3k84dr1dz4,r4pe8bez3/4ne3bq4bew2j92gea jx4hq me-2d8 e3hy4hi2ty k84!

derliang wrote:
嗯嗯,的確這樣就ok...(恕刪)


全部都要設在這個 bridge interface 上.
FB:VoIP電話技術交流

pctine wrote:
全部都要設在這個 b...(恕刪)


瞭解!
那請問原先的ether3,4,5都設定ether2為master port。
這些port有需要解除slave的身份,然後加入到這新bridge嗎?
irsjx2vxo3ne3k84dr1dz4,r4pe8bez3/4ne3bq4bew2j92gea jx4hq me-2d8 e3hy4hi2ty k84!

derliang wrote:
那請問原先的ether3,4,5都設定ether2為master port。
這些port有需要解除slave的身份,然後加入到這新bridge嗎?...(恕刪)


據我了解.不需要.
FB:VoIP電話技術交流
GRE Tunnel

官方文件: Interface/Gre

最早拉觸 GRE 是在 Vigor 2950 Router 上, 其功能為將兩個 IPSEC VPN tunnel 合併起來. 在 RouterOS 上設置 GRE 是相當容易, 如果要建置 site-to-site tunnel, 也可以考慮用 GRE.

這是 GRE Tunnel 的 example

(取自 mikrotik)

實作的 script 如下, 請自行套用. (實作是以小弟實際環境設定,並非依上圖網段)

# GRE Tunnel
# Home subnet: 192.168.22.0/24
# Office subnet: 192.168.38.0/24
# Home WAN IP: 114.32.xxx.xxx
# Office WAN IP: 114.34.xxx.xxx
# Peer IP: 10.0.0.1 & 10.0.0.2

# Home side
/interface gre
add keepalive=30 local-address=114.32.xxx.xxx name=gre-tunnel1 remote-address=114.34.xxx.xxx

# set peer ip
/ip address
add address=10.0.0.2/30 interface=gre-tunnel1

/ip route
add distance=1 dst-address=192.168.38.0/24 gateway=10.0.0.1

# Office side
/interface gre
add keepalive=30 local-address=114.34.xxx.xxx name=gre-tunnel1 remote-address=114.32.xxx.xxx

# set peer ip
/ip address
add address=10.0.0.1/30 interface=gre-tunnel1

/ip route
add distance=1 dst-address=192.168.22.0/24 gateway=10.0.0.2


說明
在 MikroTik 上建立 GRE Tunnel 是相當容易的, 主要是建立 GRE interface, 並設定 interface IP, 再設定 static route 就完成了. 在設定上 local-address 也可以省略不指定,
FB:VoIP電話技術交流

derliang wrote:
瞭解!那請問原先的e...(恕刪)


不需要,

用Master port 的硬體交換方式,當區網電腦在互傳資料時效率才比較好。

只要eth2加進去橋接即可。

pctine wrote:
加強 RouterO...(恕刪)


pctine大大

其實他支援指定IP位址管理
像這樣

如此一來上數的3個服務只會引許內部網路的192.168.1的網段登入(我家設備都是.1網段 所以88網段被我改了)
如果有多網段的會可以在多開幾組

c8900219 wrote:
pctine大大其實...(恕刪)


感謝分享, 已補上.
FB:VoIP電話技術交流
再談 Hinet IPv6 Dual Statck 的設定

初接觸 RouterOS 時, 不要說 IPv6, 連 IPv4 的設定都是看的霧沙沙, 但為了以 RouterBoard 取代原使用的 Vigor 2920n, 所以只好請求網友協助設定 IPv6, 幸有熱心網友協助, RouterBoard 上的 IPv6 DualStack 很快的上線了, 既然能用就沒有再去仔細研究它了.

後來 deraliang 兄問到有關由 HiNet 取得的 IPv6 prefix 到底如何配發問題, 當時也不加思索, 直接告知反正 Hinet 配發的 IPv6 prefix 是固定的, 那麼手動去設定 IPv6 address 就好了, 今天回頭再看了一下 manual, 才大致了解其中的原理.

首先 HiNet dual stack 服務.
FTTx IPv6/IPv4 Dual Stack Service
For HiNet FTTx users. There are two different types.
Fixed types: The OS of CPE must support SLAAC(RFC4862).
Non-fixed types: The OS of CPE must support IPv6 PPPoE.

RouerOS > ipv6 > dhcp-client, 在手冊上有提到 "pool-name (string; Default: ) Name of the IPv6 pool in which received IPv6 prefix will be added", 這就是關鍵的地方. 在 IPv6 up 時, 系統會自動新增一 IPv6 pool 出來 (當初還以為此 IPv6 pool 是手動建出來的,因系統也並未顯示此pool 為 dynamic)


而 lan port 的 IPv6 address 自然要去引用前面所生成的 IPv6 pool, 設定如下:



在 manual 上有提到:
Ipv6 address. Allowed netmask range is 0..128. Address can also be constructed from the pool if from-pool property is specified.
For example if address is set to ::1/64 then address will be constructed as follows <prefix_from_pool>::1/64

所以我們只要在 address 設為 ::1, 它就會將 IPv6 prefix 和這裡的 address 組合成 IPv6 address.

如下,一開始我們先 disable ipv6 dhcp-client, 此時 LAN IP 為無效的 ::1 位址, 當 enable 後, IPv6 up 時, LAN IP 即自動生成有效位址.


至於後續的設定請參考之前的說明, 就不再詳述了.

export bug
ipv6 address export 有一個 bug, 雖然我們只設定 :;1, 但 export 時它會自動代入已組合完成的 IPv6 address, 這是錯誤的, 已反應給原廠.(原廠回覆:v6會修正此bug)
FB:VoIP電話技術交流
評分
複製連結
請輸入您要前往的頁數(1 ~ 734)