[研究所] MikroTik RouterOS 學習 (持續更新)

回報一下各VPN用P2P打流量可以達到的速度
測試環境設定如下

Server side:Hinet 固定制 6IP 100M/100M
硬體:RB1100AHx2
有設定dstnat給VPN客戶端IP

Client side:Hinet 浮動制 100M/100M
硬體:MacBook Pro 2011 early 頂規
虛擬機:VMware Fusion Professional Version 5.03 (1040386)
虛擬機網路設定:Bridged Networking Autodetect
虛擬系統:Windows 7 Ultimate x64,8 vCPU,4GB RAM
軟體:同時開啟 EX2、Perfect Dark 1.10

每種VPN各測試30分鐘,斷線自動重撥間隔60秒。皆使用超熱門檔案測試
大大們就別問是哪些檔案了



測試結果:
PPTP VPN:可以順利搜尋,但是檔案完全不會動!
L2TP/IPsec VPN:最高速度只有10Mbps左右,途中斷線3次。
SSTP VPN:最高瞬間速度有超過60Mbps,途中斷線2次。
Open VPN:速度和SSTP VPN大致相同,途中斷線2次。

速度在50Mbps左右的時候,CPU負載在23%~30%左右
以上資訊供各位大大參考,一般環境請不要這樣玩

eavictor wrote:
測試結果:
PPTP VPN:可以順利搜尋,但是檔案完全不會動!
L2TP/IPsec VPN:最高速度只有10Mbps左右,途中斷線3次。
SSTP VPN:最高瞬間速度有超過60Mbps,途中斷線2次。
Open VPN:速度和SSTP VPN大致相同,途中斷線2次。

速度在50Mbps左右的時候,CPU負載在23%~30%左右
以上資訊供各位大大參考,一般環境請不要這樣玩
)


請問這是在有 mangle 或 QoS 下嗎?

RB1100AHx2 應該很強大了,有點意外跑不到 100M

用台 i3 跑 x86 的 RouterOS 應該要能輕易的破 100M?

chrisintaipei wrote:
請問這是在有 man...(恕刪)


回答:沒有,僅有四條IP>Firewall NAT規則

2條dstnat規則,分別指定 tcp 和 udp port 給VPN Client
2條srcnat規則,給家裡 10.0.1.0/24 和 VPN撥號的 10.0.2.0/24 這兩個網段可以順利連上網際網路

沒到100M可能是中間環節有小弟沒注意到的地方
小弟使用RouterOS 做pppoe server
沒開任何限制 單個client測速卻只能跑180M左右
google許久始終找不到答案

CPU Xeon E5-2620 4G RAM
效能方面應該不是問題

希望能幫忙指點一下

hi54yy wrote:
小弟使用RouterOS 做pppoe server, 沒開任何限制 單個client測速卻只能跑180M左右
(恕刪)


不曉得你對外的頻寬有多少? 另外如果大致描述一下你的網路架構, 大家也比較了解你的需求.
FB:VoIP電話技術交流
IPSEC - Client to Server 實作

官方文件: IPEC between MikroTik router and a Shrew client

這份官方文件算是實作上最容易的, 而且 client 端的 VPN 軟體也是 free 的.

Router 端的設定只有下面二行.

/ip ipsec proposal
set [ find default=yes ] auth-algorithms=md5,sha1 enc-algorithms=3des,aes-128,aes-192,aes-256

/ip ipsec peer
add address=0.0.0.0/0 auth-method=pre-shared-key generate-policy=yes secret=123


Shrew VPN client 下載網址

IPSEC VPN 設定和官網上大致相同, 不同有些加密方式小弟保持為 auto, 未再特別指定.


這樣就完成設定! 連線後再去 ping 看看 remote network 裡的 server or PC 測試.

FB:VoIP電話技術交流
小弟用了ovpn

很詭異的現象
用兩台MiktoTik架設

A地 server
內部網段10.10.10.1/24

B地 client
內部網段192.168.88.1/24 撥到A地 取得10.10.10.250/24


B地可以正確存取server lan端的資源
可是server端的卻沒辦法連到client端的lan
不過server端可以存取到client端winbox 8291的port


ovpn是設定成tap模式
client端有設定
src-nat action=masquerade out-interface=ovpn-out
dst-nat 將10.10.10.250轉到想要存取的對應內部ip的port

請問這有可能是哪個東西沒設定到呢?

題外話
小弟用的RB951-2n不知為何 每天都會不定時重啟

Bad Blocks

官方文件: Bad Block



如圖, 在 MikroTik router > system resource 裡有數個欄位提及 sector & bad blocks, 對於 flash 網友很關注及寫入的次數及壽命, 如同官方文件所言, 除非 bad sectors 的數字過多, 不然對於系統運作是沒有影響的, 小弟這台 RB951 是 0.0%

另外一個關注的焦點是 "Total Sector Writes", 為了延長 NAND flash 的使用壽命, 可以試著將一些寫入 flash 頻繁的 service 加以最佳化, 例如 web proxy 可以將 cache 設到外接的 usb storage or memory card, 如果 flash 寫入異常的多, 可以檢視 system > logging, web proxy 等設定, 是不是有設為 write to disk.

不過除非 User 使用了 web proxy & write to internal disk. 不然正常的情況下, flash 寫入的次數是不會增加的太快的, 此部份 user 倒可以放心.
FB:VoIP電話技術交流
小弟的機器

sector write大約每小時500次
一天會寫個12000次左右

沒有設定web cache DHCP lease也不存
這個數值似乎 很難降低
不過就用 應該沒什麼差
原廠已經放出6.0rc12的更新
想請問各位大大,有人更新之後SSTP VPN無法連線嗎?

小弟更新後就出現這個情況,恢復原廠設定後“手動重設”也無解
如果各位大大也有遇到這個情況的話就可以認定是新的bug
評分
複製連結
請輸入您要前往的頁數(1 ~ 736)