[研究所] MikroTik RouterOS 學習 (持續更新)

是的, 我早一陣子試過其中1部Vigor 3200n死機, 透過VPN撥入另1部Vigor 3200n重啟PoE switch.
How to block websites

在 RouterOS 如何 block 特定的 web site, 例如不允許上 facebook.com 網站. 在 RouterOS 裡可以透過 ip firewall filter 或是 web proxy 來達到此目的.

官方文件: How to block websites

大致做法如下.

/ip proxy access add dst-host=*.facebook.com action=deny


其他 block 特定檔案 (如 *.mp3), 在官方文件上有詳細說明.

用 firewall rules 來做
另一種做法是利用 ip firewall filter, 不過這種方式比較 '粗糙', 有可能造成誤判.


/ip firewall filter
add action=drop chain=forward content=www.test.com.tw disabled=no dst-port=80 \
protocol=tcp

FB:VoIP電話技術交流
RouterBoard overclock

RB450G CPU 預設為 680Mhz, 系統可允許調整至 800Mhz, 不過小弟是不建議啦! firewall 穩定最重要.

system > routerboard
FB:VoIP電話技術交流
Block P2P & Layer7 protocol

很多網友希望能夠針對 p2p (bt, emule...) or 特定的軟體 (skype, msn, vnc...) 做到攔阻, 在 RouterOS 可以透過 ip firewall 來實行.

如下, 在 ip firewall filter, 系統已預設 p2p 軟體. 選擇所欲 block 之 p2p 軟體, 並於 action 指定 drop 封包即可.


除了系統預設的這些 P2P 軟體外, 另外可以透過 Layer7 protocol 來 block.

官方文件: ip firewall filter
官方文件: Layer7 filter

至上述 Layer7 filter 官方網頁, 匯入相關 layer7 protocol 的 script file.(click here)

再於 ip firewall filter 選取欲 block 軟體.


不過有些軟體不斷在更新, 不見得都能夠 block 掉.

其他參考資源
L7 filter project
FB:VoIP電話技術交流
WAN 多個固定IP上網設定 - Alias

WAN 多個固定 IP, 並設定 one-on-one NAT (address mapping)

WAN IP1: 10.0.0.216 <-address mapping-> LAN:192.168.0.4
WAN IP2: 10.0.0.217 (NAT pool)

(取自 MikroTik 官網)

官方文件: link public address to local ones
FB:VoIP電話技術交流
pctine wrote:
根據所使用的 RouterBoard 至官網 download 區 > Upgrade package 下載檔案回來. 至今日 RB450G 最新版本為 v5.23....(恕刪)


p大,這似乎只能升級內建的RouterOS而無法升級硬體開機的韌體。
原廠的文件另外有介紹如何升級Bootloader firmware,官方文件
中文說明(代理商:立誠電腦提供)
RB450G最新的Bootloader firmware為ar7100-3.02.fwf,但不知該如何更新。

p大方便實作分享一下嗎?
irsjx2vxo3ne3k84dr1dz4,r4pe8bez3/4ne3bq4bew2j92gea jx4hq me-2d8 e3hy4hi2ty k84!

derliang wrote:
p大,這似乎只能升級...(恕刪)


在 1f 有 bootloader upgarde 連結.

我的 RB450G 買來時已更新至最新版本, 至於 RB750GL 剛才試過了, 確實可以 upgrade.

如下. (其實原 force-backup-booter就是 no 了)

/system routerboard print
/system routerboard settings set force-backup-booter=no
/system routerboard upgrade
/system reboot
FB:VoIP電話技術交流
winbox for Mac

小弟有時候也會使用 Macbook Air, 原 winbox 只支援 windows OS, 現己有人將其封裝成 Mac 下可以執行的程式, 直接下載官網所寫的 54.4mb 程式執行即可.

winbox for Mac



更新:
http://joshaven.com/resources/tools/winbox-for-mac/
FB:VoIP電話技術交流
請教~

多WAN時,可以設定成自動平衡嗎?

不然多WAN時,WAN2好像都沒用到比較多~

rain1955 wrote:
多WAN時,可以設定成自動平衡嗎?...(恕刪)


小弟還沒有學到這部份, 這就要看看有沒有熱心網友願意分享了.
FB:VoIP電話技術交流
評分
複製連結
請輸入您要前往的頁數(1 ~ 735)