[研究所] MikroTik RouterOS 學習 (持續更新)

樓主的分享很有用! 感謝分享!
我自己買了一台,不過真的很難上手, 需要相對觀念,才有機會!
若連基本觀念都沒的話,還是用現成比較快些!因為蛇摸是Interface 都不是很清楚!
小弟分享一下剛開始買到RB450G之後自己做的筆記,適用於一開始買來趕快設定好可以上網查詢更多資訊這樣。


1.使用Winbox登入


2.設定系統時間
在system>clock底下先設定系統時間


3.設定NTP
在system>ntp client設定NTP




4.設定介面IP
IP>Address



5.設定ADSL帳號密碼
PPP裡面新增一個PPPoE Client





6.設定NAT
IP>Firewall底下,NAT的標籤裡面設定

Chain的部分要選擇”srcnat”


Action的地方選擇”masquerade”



7.設定只有內部網路才可以登入路由器
在IP>Services裡面設定只有內部網路才可以登入
阿傑0439 wrote:
小弟分享一下剛開始買...(恕刪)


感謝分享, 已將此篇加在連結內了. 不過我把 "第一次設定那篇重寫過了', 因為現在的 routerboard 第一次設定非常容易, 已經都自動設好很多參數了.

剛拿到 RB450G 時, 因為大家都說 RouterBoard 很難, 所以自己也不敢去重新 reset, 但現在發現 routerboard 的 backup & restore 機置做的非常好, 重新設定也相當快.
FB:VoIP電話技術交流
請問關於時間部份,我的RB450G一直有個問題,雖然很少重開,但是重開以後,時間都會先變成1970/xx/xx,一段時間後才正常,我猜是連去NTP要時間,但是這樣一開使的log都會亂掉,Rb450g沒有辦法跟電腦一樣reboot前保留目前時間嗎?
phoenix2004 wrote:
請問關於時間部份,我...(恕刪)


Routerboard主機板上面並沒有設計電池可以記憶.

所以重開機時都會reset 時間,

但這並不是問題,Routerboard開機完後幾秒鐘內就會自定校時時間完成了(ntp client)


tan87888 wrote:
我自己買了一台,不過真的很難上手, 需要相對觀念,才有機會!
若連基本觀念都沒的話,還是用現成比較快些!因為蛇摸是Interface 都不是很清楚!! ...(恕刪)


現在的 RouterBoard 初始設定也都自動化了, 還蠻容易的啦.
FB:VoIP電話技術交流
有關 upgrade and downgrade firmware 部份, 重新寫過了, 將實際操作的過程補上.
FB:VoIP電話技術交流
官網已於今天釋出 v5.24 版本.

What's new in 5.24 (2013-Feb-19 15:29):

*) l2tp - fixed problem with reconnects when it added multiple ip addresses;
*) wireless - fixed AES encryption speed issues (upgrade suggested);
*) lcd - changed gamma, which gives greater contrast
*) fix reboot when running on third party hypervisors;
*) ppp client - fixed possible loss of configuration after reboot for some modems;
*) fixed wifi led order on "SXT Lite5";
FB:VoIP電話技術交流
NAT - Port Forwarding

在一般 IP 分享器上有所謂的 Virtual Server or Port Forwarding, 例如, 小弟架了一個網站, 以下是以 Vigor 2920 為例, web server 內部 IP 為 192.168.22.10


而在 RouterOS 是以 ip firewall nat 設定. 在官方文件裡找到了二則有關 NAT 方面的資料.

How to link Public addresses to Local ones
Forwarding a port to an internal IP

上述都是以固定 IP 為例. 設置大致如下.

/ip firewall nat add chain=dstnat dst-address=69.69.69.69 protocol=tcp \
dst-port=80 action=dst-nat to-addresses=192.168.22.10 to-ports=80


但如果 WAN IP 是 dynamic IP 呢? 很簡單, 直接用 in-interface 來做就好

/ip firewall nat
add action=dst-nat chain=dstnat comment="http server" disabled=no \
dst-port=80 in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.22.10 \
to-ports=80


2013/11/18更新
WAN 為 dynamic IP 的 port forwarding 也可以利用 dst-address-type=local 來達成, 此時就不需要指定 in-interface

/ip firewall nat
add action=dst-nat chain=dstnat comment="Synology DSM" dst-address-type=local \
dst-port=5000-5006 protocol=tcp to-addresses=192.168.22.10 to-ports=\
5000-5006

FB:VoIP電話技術交流
小弟最近才剛剛買進一台 RB750,手上有收費 VPN service,想要用 RB750 當成 VPN client 翻牆。

有網友知道如何在 RouterOS 上設定 L2TP/IPSec or SSTP VPN client 嗎?

最近一陣子中國封鎖 OpenVPN 很嚴重所以想用 L2TP/IPSec or SSTP VPN 來翻牆。


感謝感謝!!
評分
複製連結
請輸入您要前往的頁數(1 ~ 735)