用了新版本 這次卻出現

insmod: init_module '/sdcard/modules/fuse.ko' failed (Operation not permitted)

besttribal wrote:
用了新版本 這次卻出現

insmod: init_module '/sdcard/modules/fuse.ko' failed (Operation not permitted)


沒有先執行 su ? 所以沒有權限
有執行 su內.....重開機 也試過了~"~

besttribal wrote:
有執行 su內......(恕刪)


有Root嗎?

指令的起始有變#字嗎!?

linhsiaohung wrote:
有Root嗎?指令的...(恕刪)


有root 我直接貼照片給你>< 幫幫忙唷....

http://www.flickr.com/photos/[email protected]/5973817035/in/photostream

besttribal wrote:
有root 我直...(恕刪)


insmod: init_module xxxx failed (File exists)

-> 這個應該是你之前已有載入過 fuse.ko 模組了
可以不用理它


ntfs-3g: Failed to access volume '/dev/block/sda1' xxxxxx
這個是說你的系統無法存取外接裝置的 Partition 1
有可能是
1. 外接裝置不支援
2. 第一個磁區 (sda1) 沒處理好
besttribal板友辛苦了,我看了一下你遇到過的
1. fuse.ko 格式錯誤 (訊息: Exec format error)
2. insmod 沒有執行權限 (訊息: Operation not permitted)
3. /dev/block/sda1 不存在 (訊息: no such file or directory)


先恭喜你前 2 個問題解決了,
關於第 3 點,上面冏大,說的原因完全正確。

原因可能很多,可能硬碟沒插好, 我只能建議你多插多試看看。只能靠自己排除。

多試誤幾次總會形成一套固定可行的模式,我附上我自己認為可行步驟的圖片。
請先比較看看,你的步驟中,和我的步驟是否有差異,差異性有沒有影響。

1.還沒插上手機之前,先確認硬碟是有電源的

(圖片中是用2003年買的三星120G 2.5"硬碟, 內附一條 1對2可外接電源的USB線,
已接上 USB OTG 線,
左邊是電池大廠 sanyo 5000mah行動電源(2010),背景是公司配的 2011年 macbook)

2.插上 USB OTG 線到手機上,會看到USB host已連接訊息


3.緊接著,會看到USB設備已連接訊息,表示知道有硬碟存在。


4.緊接著,因為NTFS格式不認得的關係,會看到不明的USB硬碟裝置圖示
(圖示依美化包不同,會用不同的圖片顯示)


這一階段,可能有幾種訊息狀況,
1).若接上可用裝置,會看到直接成功的訊息。(無圖),如不需電源的"滑鼠",或"外接讀卡機"
會直接掛載在 /sdcard/usbStorage上,FAT/FAT32格式的硬碟也是一樣。
2).若裝置需要外部電源,若沒提供電源,會看到需要電源的錯誤訊息。(無圖)
3).以及上面這種,電源沒問題,也知道是儲存裝備,但檔案格式不認得。

5.接下來就簡單了,執行 Terminal Emulator,輸入 a Enter 掛載,理論上應該沒問題。


6.開啟檔案總管直接可以看硬碟內容,左上角裝置不明格式訊息不用理他。


7.拔掉之前,要再執行 Terminal Emulator,輸入 b Enter 卸載。


附錄
1. df 指令可以看到掛載的情況
圖片中可以看到,/dev/block/sda1(硬碟的代號) 120GB掛載到 /mnt/usb 下面。

這訊息只是看爽的,掛載失敗就不會有,掛載失敗時這指令沒有幫助。

2. dmesg 這個 unix 指令就有幫助了。可以看到硬體狀況,
dmesg | grep block (過濾 block 字樣)
如圖,可以看到,他有 sda1 外接硬碟


先這樣,請參考我的步驟,你的問題應該在 4 點,插上去後手機的反應。
請再多試看看。

(若有需要,歡迎轉載使用)

blueeyecc wrote:
besttribal...(恕刪)


這也太詳細了吧...

藍眼大真有心~
謝謝 上面幾位大大解說 小弟剛下班 才看到!!

剛剛 那意思是 我設定跟檔案 放置的位置 都沒錯

有問題是在於我的隨身碟嗎??

因為我是用16g的隨身碟 也不是硬碟需要 供電...

奇怪的現象就是

1.我把OTG先插上手機 再插隨身碟 他會出現 USB HOST已連接

再來插上隨身碟 他會說

"已連接高功率的USB裝置...無法連接裝置 連接的裝置需要外部電源"...

隨身碟哪邊的外部電源......??

然後輸入 su a 之後 會出現這張圖

http://www.flickr.com/photos/[email protected]/5977492112/in/photostream


2.如果 我先把OTG 跟 隨身碟接在一起 然後一起插上手機 他就會說

"USB儲存裝置無內容或不支援檔案格式"

輸入 su a之後 會出現 這張圖

http://www.flickr.com/photos/[email protected]/5976928713/in/photostream

各位大大這麼熱心幫忙 我也奉上圖片 希望 可以克服這個困難阿 昏倒~~

再次感謝各位





blueeyecc wrote:
引用第20樓內容先確...(恕刪)

感謝大大的熱心教學^^
關閉廣告
文章分享
評分
複製連結
請輸入您要前往的頁數(1 ~ 9)

今日熱門文章 網友點擊推薦!