Google (Android) - Google Nexus 4/5/7 NFC不適用中華電信 NFC行動支付 - 手機

前往內容


Google Nexus 4/5/7 NFC不適用中華電信 NFC行動支付







無法安裝是因為沒有"org.simalliance.openmobileapi"
所以加進去後就可以使用"Easy Hami"和"Easy Wallet NFC"
不過是否能用SWP SIM我就無法測試了
可能會需要動到libnfc-brcm.conf,libnfc-brcm-20791b05.conf


org.simalliance.openmobileapi(open mobile api):
201410/mobile01-414f74b5add6a23c0d2e6b5211de0b8c.zip
MEGA


使用root explorer之類的文件管理
"org.simalliance.openmobileapi.xml"放到"/system/etc/permissions/" 改權限644
"org.simalliance.openmobileapi.jar"放到"/system/framework/" 改權限644
重新開機就ok了

Easy Hami v1.0.1
Easy Wallet NFC v1.1.02
想不到 LG 沒關掉 QCT 的那段路, 不然僅有 org.simalliance.openmobileapi 是不夠的才是.

jhulude wrote:
無法安裝是因為沒有"...(恕刪)

jhulude wrote:
無法安裝是因為沒有"org.simalliance.openmobileapi"


感謝 jhulude 兄的說明~ 這個困擾了我好久...
找了一下,是因為電子錢包類的程式,都有呼叫 org.simalliance.openmobileapi.jar
相關的 API ...

感謝您~~
NFC目前有二大主流標準。

一個是早期的NXP半導體公司的Mifare Classic。
另一個為近期的NFC Forum's Standards(共有4個type)。

這二個系統基本上不相容。
就看手機或是平板的NFC是採用那家的晶片。

如果是採用NXP的晶片,那通常二種標準的Tag都可以讀寫。
(註: NXP亦是NFC Forum的主要成員之一)

如果是採用非NXP(如Broadcom)的晶片,那大概就只支援NFC Forum's Standard
的NFC Tag。

正好悠遊卡就是用Mifare Classic技術的感應卡/讀卡機,不是使用NFC Forum's Standards技術的
這是造成Broadcom的NFC晶片在台灣無法正常使用的主因,Nexus 7倒是有希望可以使用就是!
基本上不是規格的問題,是跟GOOGLE 想要的不一致造成的.

像是三星Note3就有支援。

Samsung Galaxy Note 3 LTE N9005 [NXP PN544 / Broadcom BCM20794]

在中國有人就可以用SWP-SIM來撘公交車。

Nexus5 公交卡



目前我手上沒有中華電信SWP-SIM沒有辦法可以用,目前的想法如下:


1。先ROOT Nexus5
Nexus5 Root Kit
2. 將/system 改成可以RW
C:\> adb shell
> su
# mount -o rw,remount /system
3. COPY 附件 至 /system/etc
4. 照樓上4樓的做法加入API
5. 將/system改成RO
6. 重開機。


應該就可以用中華NFC SIM



附加壓縮檔: 201410/mobile01-6abad2e2a461efdfc43e01c57c78bf65.zip
Succubus wrote:
基本上不是規格的問題...(恕刪)


但是Samsung Galaxy Note 3 LTE N9005的NFC晶片,二家都有耶......
如果沒意外,台灣的是用NXP PN544那批
來源:
Samsung Splits Supply Contracts NFC Chips Galaxy Note 3 Between Broadcom and NXP
還有中國使用的是Sony主導的FeliCa的技術,而非NXP主導的Mifare Classic
技術規格本身就不同了,所以中國能用還真的不代表台灣能用
想要使用Mifare Classic要跟NXP買授權,Broadcom擺明不買單阿......
我去Samsung版問一下現在手上有Note 3 LTE的人看一下NFC晶片是哪家的好了

1頁 (共4頁)

前往